<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://linuxconcept.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://linuxconcept.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://linuxconcept.com';var et_post_id='2172';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Operating System (OS) Definition and types of Operating System</title>

<!-- This site is optimized with the Yoast SEO plugin v11.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="When we talk about Operating System, we found it is a program which acts as a controller and helps to control hardware for a user."/>
<link rel="canonical" href="https://linuxconcept.com/what-is-an-operating-system/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Operating System (OS) Definition and types of Operating System" />
<meta property="og:description" content="When we talk about Operating System, we found it is a program which acts as a controller and helps to control hardware for a user." />
<meta property="og:url" content="https://linuxconcept.com/what-is-an-operating-system/" />
<meta property="og:site_name" content="Linux Concept" />
<meta property="article:publisher" content="https://www.facebook.com/linuxconcept" />
<meta property="article:section" content="Operating System" />
<meta property="article:published_time" content="2019-04-13T16:53:54+00:00" />
<meta property="article:modified_time" content="2019-04-20T20:24:53+00:00" />
<meta property="og:updated_time" content="2019-04-20T20:24:53+00:00" />
<meta property="og:image" content="https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png" />
<meta property="og:image:secure_url" content="https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png" />
<meta property="og:image:width" content="795" />
<meta property="og:image:height" content="447" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="When we talk about Operating System, we found it is a program which acts as a controller and helps to control hardware for a user." />
<meta name="twitter:title" content="Operating System (OS) Definition and types of Operating System" />
<meta name="twitter:site" content="@Linux_Concept" />
<meta name="twitter:image" content="https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png" />
<meta name="twitter:creator" content="@Linux_Concept" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://linuxconcept.com/#organization","name":"LinuxConcept","url":"https://linuxconcept.com/","sameAs":["https://www.facebook.com/linuxconcept","https://twitter.com/Linux_Concept"],"logo":{"@type":"ImageObject","@id":"https://linuxconcept.com/#logo","url":"https://linuxconcept.com/wp-content/uploads/2019/01/Logo.png","width":375,"height":100,"caption":"LinuxConcept"},"image":{"@id":"https://linuxconcept.com/#logo"}},{"@type":"WebSite","@id":"https://linuxconcept.com/#website","url":"https://linuxconcept.com/","name":"LinuxConcept","publisher":{"@id":"https://linuxconcept.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://linuxconcept.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://linuxconcept.com/what-is-an-operating-system/#primaryimage","url":"https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png","width":795,"height":447,"caption":"Linux Concept - what is an operating system image"},{"@type":"WebPage","@id":"https://linuxconcept.com/what-is-an-operating-system/#webpage","url":"https://linuxconcept.com/what-is-an-operating-system/","inLanguage":"en-US","name":"Operating System (OS) Definition and types of Operating System","isPartOf":{"@id":"https://linuxconcept.com/#website"},"primaryImageOfPage":{"@id":"https://linuxconcept.com/what-is-an-operating-system/#primaryimage"},"datePublished":"2019-04-13T16:53:54+00:00","dateModified":"2019-04-20T20:24:53+00:00","description":"When we talk about Operating System, we found it is a program which acts as a controller and helps to control hardware for a user."},{"@type":"Article","@id":"https://linuxconcept.com/what-is-an-operating-system/#article","isPartOf":{"@id":"https://linuxconcept.com/what-is-an-operating-system/#webpage"},"author":{"@id":"https://linuxconcept.com/#/schema/person/35e048a9c748373660717c6655baaad5"},"headline":"What is an Operating System?","datePublished":"2019-04-13T16:53:54+00:00","dateModified":"2019-04-20T20:24:53+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://linuxconcept.com/what-is-an-operating-system/#webpage"},"publisher":{"@id":"https://linuxconcept.com/#organization"},"image":{"@id":"https://linuxconcept.com/what-is-an-operating-system/#primaryimage"},"articleSection":"Operating System"},{"@type":["Person"],"@id":"https://linuxconcept.com/#/schema/person/35e048a9c748373660717c6655baaad5","name":"SATISH KUMAR","image":{"@type":"ImageObject","@id":"https://linuxconcept.com/#authorlogo","url":"https://secure.gravatar.com/avatar/956811c02d7e30b15f9d748da8c280a0?s=96&d=mm&r=g","caption":"SATISH KUMAR"},"description":"I am Satish Kumar, Founder of LinuxConcept. Linux and F.O.S.S enthusiast, love to work on open source platform and technologies.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Linux Concept &raquo; Feed" href="https://linuxconcept.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Concept &raquo; Comments Feed" href="https://linuxconcept.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Concept &raquo; What is an Operating System? Comments Feed" href="https://linuxconcept.com/what-is-an-operating-system/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxconcept.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="linuxconcept v.1.0.0" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://linuxconcept.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-css'  href='https://linuxconcept.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=1.7.9' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://linuxconcept.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=1.7.9' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-css-css'  href='https://linuxconcept.com/wp-content/plugins/monarch/css/style.css?ver=1.4.12' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='et-gf-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://linuxconcept.com/wp-content/themes/Extra/style.css?ver=5.2.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://linuxconcept.com/wp-content/themes/LinuxConcept/style.css?ver=2.27.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://linuxconcept.com/wp-includes/css/dashicons.min.css?ver=5.2.2' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://linuxconcept.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://linuxconcept.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[]};
var log_object = {"ajax_url":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=1.7.9'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/themes/LinuxConcept/ds-script.js?ver=5.2.2'></script>
<link rel='https://api.w.org/' href='https://linuxconcept.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxconcept.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxconcept.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://linuxconcept.com/?p=2172' />
<link rel="alternate" type="application/json+oembed" href="https://linuxconcept.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxconcept.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;format=xml" />

<!-- StarBox - the Author Box for Humans 3.2.6, visit: http://wordpress.org/plugins/starbox/ -->
<meta property="article:author" content="https://www.facebook.com/satishkumar1986" />
<!-- /StarBox - the Author Box for Humans -->

<link rel='stylesheet' id='ABHfrontend.min.css-css'  href='https://linuxconcept.com/wp-content/plugins/starbox//themes/business/css/frontend.min.css?ver=3.2.6' type='text/css' media='all' />
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/starbox//themes/business/js/frontend.min.js?ver=3.2.6'></script>
<link rel='stylesheet' id='ABHhidedefault.min.css-css'  href='https://linuxconcept.com/wp-content/plugins/starbox//themes/admin/css/hidedefault.min.css?ver=3.2.6' type='text/css' media='all' />
<style type="text/css" id="et-bloom-custom-css">
					.et_bloom .et_bloom_optin_3 .et_bloom_form_content { background-color: #ffffff !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_container .et_bloom_form_header { background-color: #dd4242 !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_content .et_bloom_fields i { color: #3b3b3b !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_content .et_bloom_custom_field_radio i:before { background: #3b3b3b !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_3 .et_bloom_form_container h2, .et_bloom .et_bloom_optin_3 .et_bloom_form_container h2 span, .et_bloom .et_bloom_optin_3 .et_bloom_form_container h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_3 .et_bloom_form_container p, .et_bloom .et_bloom_optin_3 .et_bloom_form_container p span, .et_bloom .et_bloom_optin_3 .et_bloom_form_container p strong, .et_bloom .et_bloom_optin_3 .et_bloom_form_container form input, .et_bloom .et_bloom_optin_3 .et_bloom_form_container form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } .et_bloom .et_bloom_optin_4 .et_bloom_form_content { background-color: #ffffff !important; } .et_bloom .et_bloom_optin_4 .et_bloom_form_container .et_bloom_form_header { background-color: #dd4242 !important; } .et_bloom .et_bloom_optin_4 .wedge_edge .triangle { fill: #dd4242} .et_bloom .et_bloom_optin_4 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_4 .et_bloom_form_content .et_bloom_fields i { color: #3b3b3b !important; } .et_bloom .et_bloom_optin_4 .et_bloom_form_content .et_bloom_custom_field_radio i:before { background: #3b3b3b !important; } .et_bloom .et_bloom_optin_4 .et_bloom_form_content button { background-color: #3b3b3b !important; } .et_bloom .et_bloom_optin_4 .et_bloom_form_container h2, .et_bloom .et_bloom_optin_4 .et_bloom_form_container h2 span, .et_bloom .et_bloom_optin_4 .et_bloom_form_container h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_4 .et_bloom_form_container p, .et_bloom .et_bloom_optin_4 .et_bloom_form_container p span, .et_bloom .et_bloom_optin_4 .et_bloom_form_container p strong, .et_bloom .et_bloom_optin_4 .et_bloom_form_container form input, .et_bloom .et_bloom_optin_4 .et_bloom_form_container form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } 
				</style><style type="text/css" id="et-social-custom-css">
				.et_monarch .et_social_sidebar_networks li, .et_monarch .et_social_mobile li { background: #ffffff; } .et_monarch .et_social_sidebar_networks .et_social_icons_container li:hover, .et_monarch .et_social_mobile .et_social_icons_container li:hover { background: #000000 !important; } .et_social_sidebar_border li { border-color: #000000 !important; } .et_monarch .et_social_sidebar_networks .et_social_icons_container li i, .et_monarch .et_social_sidebar_networks .et_social_icons_container li .et_social_count, .et_monarch .et_social_mobile .et_social_icons_container li i, .et_monarch .et_social_mobile .et_social_icons_container li .et_social_count { color: #000000; } .et_monarch .et_social_sidebar_networks .et_social_icons_container li:hover i, .et_monarch .et_social_sidebar_networks .et_social_icons_container li:hover .et_social_count, .et_monarch .et_social_mobile .et_social_icons_container li:hover i, .et_monarch .et_social_mobile .et_social_icons_container li:hover .et_social_count { color: #ffffff !important; } 
			</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />		<script type="text/javascript">
			var cli_flush_cache=2;
		</script>
		<link rel="amphtml" href="https://linuxconcept.com/what-is-an-operating-system/amp/"><script>
var year = new Date();
year = year.getFullYear();
jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://linuxconcept.com">LinuxConcept</a>. All Rights Reserver');
});
</script>

<meta name="google-site-verification" content="n27r5Cp1-X06ZJVC6rGH0qSVS47Gw9R20vmIaWDjc50"><meta name="msvalidate.01" content="E4169AFEE82DC7EE2F40A80C184B323D"><meta name="yandex-verification" content="cb8ff5c89ecb1ed8"><!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '286612895566977');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=286612895566977&amp;ev=PageView&amp;noscript=1"></noscript>
<!-- End Facebook Pixel Code -->
<link rel="preload" href="/wp-content/plugins/bloom/css/fonts/ET-Bloom.woff" as="fonts"><link rel="icon" href="https://linuxconcept.com/wp-content/uploads/2019/02/favicon-150x150.png" sizes="32x32" />
<link rel="icon" href="https://linuxconcept.com/wp-content/uploads/2019/02/favicon.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://linuxconcept.com/wp-content/uploads/2019/02/favicon.png" />
<meta name="msapplication-TileImage" content="https://linuxconcept.com/wp-content/uploads/2019/02/favicon.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://linuxconcept.com/wp-content/cache/et/global/et-extra-customizer-global-15661423499209.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-2172 single-format-standard et_bloom et_monarch et_extra et_pb_pagebuilder_layout et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_fadeInTop et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
	<div id="page-container" class="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="">
						<ul id="et-secondary-menu" class="nav"><li id="menu-item-65" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65"><a href="https://linuxconcept.com/linux-commands-cheat-sheet/">A-Z Linux Commands</a></li>
<li id="menu-item-1538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1538"><a href="https://linuxconcept.com/category/mcq/">MCQ</a></li>
<li id="menu-item-3659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3659"><a target="_blank" rel="noopener noreferrer" href="https://in.jooble.org/">Jobs in India</a></li>
</ul>						</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-top-search -->
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="60">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://linuxconcept.com/" data-fixed-height="51">
							<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Linux Concept" id="logo" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/01/Logo.png" /><noscript><img src="https://linuxconcept.com/wp-content/uploads/2019/01/Logo.png" alt="Linux Concept" id="logo" /></noscript>
						</a>

						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav et_disable_top_tier"><li id="menu-item-1507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1507"><a href="https://linuxconcept.com/category/news/">News</a></li>
<li id="menu-item-1882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1882"><a href="#">Distros</a>
<ul class="sub-menu">
	<li id="menu-item-1487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1487"><a href="https://linuxconcept.com/category/centos/">CentOS</a></li>
	<li id="menu-item-1832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1832"><a href="https://linuxconcept.com/category/debian/">Debian</a></li>
	<li id="menu-item-1883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1883"><a href="https://linuxconcept.com/category/fedora/">Fedora</a></li>
	<li id="menu-item-1885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1885"><a href="https://linuxconcept.com/category/redhat/">Redhat</a></li>
	<li id="menu-item-1486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1486"><a href="https://linuxconcept.com/category/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-1886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1886"><a href="#">Certification</a>
<ul class="sub-menu">
	<li id="menu-item-2044" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2044"><a href="https://linuxconcept.com/certification/comptia-certification/">Comptia</a>
	<ul class="sub-menu">
		<li id="menu-item-2768" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2768"><a href="https://linuxconcept.com/comptia-linux-certification-guide/">Linux+</a></li>
	</ul>
</li>
	<li id="menu-item-2046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2046"><a href="https://linuxconcept.com/certification/linux-foundation-certification/">Linux Foundation</a>
	<ul class="sub-menu">
		<li id="menu-item-2794" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2794"><a href="https://linuxconcept.com/lfcs-certification-guide/">LFCS</a></li>
		<li id="menu-item-2793" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2793"><a href="https://linuxconcept.com/lfce-certification-guide/">LFCE</a></li>
	</ul>
</li>
	<li id="menu-item-2045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2045"><a href="https://linuxconcept.com/certification/lpi-certification/">LPI</a>
	<ul class="sub-menu">
		<li id="menu-item-2673" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2673"><a href="https://linuxconcept.com/lpi-essentials-certification-guide/">LPI Essentials</a></li>
		<li id="menu-item-2770" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2770"><a href="https://linuxconcept.com/lpic-1-linux-administrator-certification-guide/">LPIC -1</a></li>
		<li id="menu-item-2769" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2769"><a href="https://linuxconcept.com/lpic-2-linux-engineer-certification-guide/">LPIC -2</a></li>
		<li id="menu-item-2939" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2939"><a href="https://linuxconcept.com/lpic-3-mixed-environment-certification-guide/">LPIC -3: Mixed Environment</a></li>
		<li id="menu-item-2938" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2938"><a href="https://linuxconcept.com/lpic-3-virtualization-high-availability-certification-guide/">LPIC -3: Virtualization &#038; High Availability</a></li>
	</ul>
</li>
	<li id="menu-item-2047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2047"><a href="https://linuxconcept.com/certification/red-hat-certification/">Red Hat</a>
	<ul class="sub-menu">
		<li id="menu-item-2767" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2767"><a href="https://linuxconcept.com/rhcsa-certification-guide/">RHCSA</a></li>
		<li id="menu-item-2766" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2766"><a href="https://linuxconcept.com/rhce-certification-guide/">RHCE</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-1899" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1899"><a href="#">Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-2480" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2480"><a href="https://linuxconcept.com/linux-beginners-guide/">Linux Beginner’s Guide</a></li>
	<li id="menu-item-3125" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-3125"><a href="https://linuxconcept.com/apache-web-server-tutorial/">Apache Web Server</a></li>
	<li id="menu-item-3124" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-3124"><a href="https://linuxconcept.com/nginx-tutorial/">Nginx</a></li>
	<li id="menu-item-2805" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2805"><a href="https://linuxconcept.com/postfix-tutorial/">Postfix</a></li>
	<li id="menu-item-2979" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2979"><a href="https://linuxconcept.com/kvm-tutorial/">KVM</a></li>
	<li id="menu-item-2937" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2937"><a href="https://linuxconcept.com/docker-tutorial/">Docker</a></li>
	<li id="menu-item-2980" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2980"><a href="https://linuxconcept.com/ansible-tutorial/">Ansible</a></li>
	<li id="menu-item-2978" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2978"><a href="https://linuxconcept.com/xen-server-tutorial/">XenServer</a></li>
</ul>
</li>
<li id="menu-item-1901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1901"><a href="#">Monitoring</a>
<ul class="sub-menu">
	<li id="menu-item-2936" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2936"><a href="https://linuxconcept.com/nagios-tutorial/">Nagios</a></li>
	<li id="menu-item-2935" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2935"><a href="https://linuxconcept.com/zabbix-tutorial/">Zabbix</a></li>
	<li id="menu-item-2934" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2934"><a href="https://linuxconcept.com/cacti-tutorial/">Cacti</a></li>
	<li id="menu-item-2933" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2933"><a href="https://linuxconcept.com/observium-tutorial/">Observium</a></li>
	<li id="menu-item-3085" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-3085"><a href="https://linuxconcept.com/monitorix-tutorial/">Monitorix</a></li>
	<li id="menu-item-3086" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-3086"><a href="https://linuxconcept.com/collectd-tutorial/">Collectd</a></li>
</ul>
</li>
<li id="menu-item-1913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1913"><a href="#">Resource</a>
<ul class="sub-menu">
	<li id="menu-item-2156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2156"><a href="https://linuxconcept.com/linux-commands-cheat-sheet/">Commands</a></li>
	<li id="menu-item-1915" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1915"><a href="#">Interview Questions</a></li>
	<li id="menu-item-2139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2139"><a href="https://linuxconcept.com/category/mcq/">MCQ</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>

				<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-2172" class="module single-post-module post-2172 post type-post status-publish format-standard has-post-thumbnail hentry category-operating-system et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">What is an Operating System?</h1>
								<div class="post-meta vcard">
									<p>Posted by <a href="https://linuxconcept.com/author/satish/" class="url fn" title="Posts by SATISH KUMAR" rel="author">SATISH KUMAR</a> | <span class="updated">Last updated on Apr 20, 2019 | Published on Apr 13, 2019</span> | <a href="https://linuxconcept.com/category/operating-system/" rel="tag">Operating System</a> | <a class="comments-link" href="https://linuxconcept.com/what-is-an-operating-system/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="What is an Operating System?" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png" /><noscript><img src="https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image.png" alt="What is an Operating System?" /></noscript>							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<div id="et-boc" class="et-boc">
			
			<div class="et_builder_inner_content et_pb_gutters3">
				<div class="et_pb_section et_pb_section_0 et_section_regular">
				
				
				
				
					<div class="et_pb_row et_pb_row_0">
				<div class="et_pb_column et_pb_column_4_4 et_pb_column_0  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_text et_pb_text_0 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><p>When we talk about Operating System, we found it is a program which acts as a controller and helps to control hardware for a user.</p>
<p>It is available in all IoT device, or we can say it is an integral part of all connected devices which has capabilities to run applications.</p>
<p>Before getting into deep dive, we can get some generic definition for Operating System from a reliable source.</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_1 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><p>An Operating System (OS) is system software that manages computer hardware and software resources and provides common services for computer programs.<br /> <span style="color: #0000ff;"><strong>Source</strong></span> &#8211; <a href="https://en.wikipedia.org/wiki/Operating_system">wikipedia</a></p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_2 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><p>The operating system (OS) is the most important program that runs on a computer. Every general-purpose computer must have an operating system to run other programs and applications. Computer operating systems perform basic tasks, such as recognizing input from the keyboard, sending output to the display screen, keeping track of files and directories on the storage drives, and controlling peripheral devices, such as printers.</p>
<p>For large systems, the operating system has even greater responsibilities and powers. It is like a traffic cop – it makes sure that different programs and users running at the same time do not interface with each other. The operating system is also responsible for security, ensuring that unauthorized users do not access the system.<br /><span style="color: #0000ff;"><strong>Source</strong></span> &#8211; <a href="https://www.webopedia.com/TERM/O/operating_system.html">webopedia</a></p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_3 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><p>So, now we get to know the operating system is everything for a dumb box (hardware or computer system).</p>
<p>We use the operating system so a machine and human can understand each other in respect to request and response for anything.</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_4 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h2>Types of Operating System</h2>
<p>There are multiple types of Operating System; some of the important is here.</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_5 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><p>• Single and Multi-Tasking Operating System<br />• Single and multi-User Operating System<br />• Distributed Operating System<br />• Embedded Operating System</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_6 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h3>Single and multi-Tasking Operating System</h3>
<p>The entire Operating System can have divided into two parts, Single-Tasking and Multi-Tasking operating system.</p>
<p>A Single-Tasking operating system can run only one task/Program/application at a time, while a multi-tasking operating system has capabilities to run more than one task/program/application at a time.</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_7 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h4>Single and multi-user Operating System</h4>
<p>The entire Operating System can have divided into two parts, Single-User and Multi-User operating system.</p>
<p>A Single-User operating system can run multiple task/Program/application at a time but only allow a single user to log-in on the system at a time, while a multi-User operating system has capabilities to use by more than one user login at a time.</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_8 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h4>Distributed Operating System</h4>
<p>A Distributed Operating System is work with the collection of independent physically separate CPUs, RAM, networking, and system devices. They handle programs which are running on multiple CPUs. It can operate by various users and acts as a single system for everyone</p></div>
			</div> <!-- .et_pb_text --><div class="et_pb_module et_pb_text et_pb_text_9 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h4>Embedded Operating System</h4>
<p>Embedded Operating System is developed to use in Embedded devices.</p>
<p>This operating system comes with multiple capabilities like, run on limited resources, build on small devices like PDAs etc.</p></div>
			</div> <!-- .et_pb_text -->
			</div> <!-- .et_pb_column -->
				
				
			</div> <!-- .et_pb_row -->
				
				
			</div> <!-- .et_pb_section --><div class="et_pb_with_border et_pb_section et_pb_section_1 et_section_regular">
				
				
				
				
					<div class="et_pb_with_border et_pb_row et_pb_row_1">
				<div class="et_pb_column et_pb_column_4_4 et_pb_column_1  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_text et_pb_text_10 et_pb_bg_layout_light  et_pb_text_align_left">
				
				
				<div class="et_pb_text_inner"><h3 style="text-align: center;">If You Like What We Do Here On LinuxConcept, You Should Consider:</h3>
<p>Stay Connected to: <a href="https://twitter.com/Linux_Concept">Twitter</a> | <a href="https://www.facebook.com/linuxconcept">Facebook</a></p>
<p>Subscribe to our email updates: <a href="https://linuxconcept.com/subscribe-to-blog/">Sign Up Now</a></p>
<p>&nbsp;</p>
<p style="text-align: center;"><strong><span style="color: #ff0000;">We are thankful for your support.</span></strong></p></div>
			</div> <!-- .et_pb_text -->
			</div> <!-- .et_pb_column -->
				
				
			</div> <!-- .et_pb_row -->
				
				
			</div> <!-- .et_pb_section -->
                         <div class="abh_box abh_box_down abh_box_business"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">About</a></li> <li class="abh_posts"><a href="#abh_posts">Latest Posts</a></li></ul><div class="abh_tab_content"><section class="vcard abh_about_tab abh_tab" style="display:block"><div class="abh_image"><a href = "https://linuxconcept.com/author/satish/" class="url" title = "SATISH KUMAR" > <div class="et_social_media_wrapper"><div class="et_social_media_wrapper"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%200'%3E%3C/svg%3E" class="photo" width="250" alt="SATISH KUMAR" data-lazy-src="https://linuxconcept.com/wp-content/uploads/gravatar/satish-kumar.jpg" /><noscript><img src="https://linuxconcept.com/wp-content/uploads/gravatar/satish-kumar.jpg" class="photo" width="250" alt="SATISH KUMAR" /></noscript><div class="et_social_media et_social_media_hidden et_social_mobile_on">
				<div class="et_social_networks et_social_autowidth et_social_simple et_social_left et_social_rounded et_social_outer_dark">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<div data-social_link="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="facebook" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_twitter">
									<div data-social_link="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share" data-social_name="twitter" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_linkedin">
									<div data-social_link="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="linkedin" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_pinterest">
									<div data-social_link="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;media=https%3A%2F%2Flinuxconcept.com%2Fwp-content%2Fuploads%2Fgravatar%2Fsatish-kumar.jpg&#038;description=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="pinterest" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_printfriendly">
									<div data-social_link="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="printfriendly" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li></ul>
				</div>
			</div></div><div class="et_social_media et_social_media_hidden et_social_mobile_on">
				<div class="et_social_networks et_social_autowidth et_social_simple et_social_left et_social_rounded et_social_outer_dark">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<div data-social_link="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="facebook" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_twitter">
									<div data-social_link="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share" data-social_name="twitter" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_linkedin">
									<div data-social_link="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="linkedin" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_pinterest">
									<div data-social_link="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;media=https%3A%2F%2Flinuxconcept.com%2Fwp-content%2Fuploads%2Fgravatar%2Fsatish-kumar.jpg&#038;description=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="pinterest" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_printfriendly">
									<div data-social_link="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="printfriendly" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li></ul>
				</div>
			</div></div></a > </div><div class="abh_social"> <div style="clear: both; font-size:12px; font-weight:normal; width: 85px; margin: 0 0 2px auto; line-height: 20px;">Follow me</div><a href="https://www.facebook.com/satishkumar1986" title="Facebook" class="abh_facebook" target="_blank" rel="nofollow"></a><a href="https://twitter.com/satish_kumar86" title="Twitter" class="abh_twitter" target="_blank" rel="nofollow"></a></div><div class="abh_text"><h3 class="fn name" style="font-size:16px !important;"><a href="https://linuxconcept.com/author/satish/" class="url">SATISH KUMAR</a></h3><div class="abh_job" style="font-size:14px !important;"></div><div class="description note abh_description" style="font-size:14px !important;">I am Satish Kumar, Founder of LinuxConcept. Linux and F.O.S.S enthusiast, love to work on open source platform and technologies.</div></div> </section><section class="abh_posts_tab abh_tab" ><div class="abh_image"><a href="https://linuxconcept.com/author/satish/" class="url" title="SATISH KUMAR"><div class="et_social_media_wrapper"><div class="et_social_media_wrapper"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%200'%3E%3C/svg%3E" class="photo" width="250" alt="SATISH KUMAR" data-lazy-src="https://linuxconcept.com/wp-content/uploads/gravatar/satish-kumar.jpg" /><noscript><img src="https://linuxconcept.com/wp-content/uploads/gravatar/satish-kumar.jpg" class="photo" width="250" alt="SATISH KUMAR" /></noscript><div class="et_social_media et_social_media_hidden et_social_mobile_on">
				<div class="et_social_networks et_social_autowidth et_social_simple et_social_left et_social_rounded et_social_outer_dark">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<div data-social_link="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="facebook" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_twitter">
									<div data-social_link="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share" data-social_name="twitter" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_linkedin">
									<div data-social_link="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="linkedin" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_pinterest">
									<div data-social_link="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;media=https%3A%2F%2Flinuxconcept.com%2Fwp-content%2Fuploads%2Fgravatar%2Fsatish-kumar.jpg&#038;description=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="pinterest" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_printfriendly">
									<div data-social_link="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="printfriendly" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li></ul>
				</div>
			</div></div><div class="et_social_media et_social_media_hidden et_social_mobile_on">
				<div class="et_social_networks et_social_autowidth et_social_simple et_social_left et_social_rounded et_social_outer_dark">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<div data-social_link="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="facebook" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_twitter">
									<div data-social_link="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share" data-social_name="twitter" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_linkedin">
									<div data-social_link="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="linkedin" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_pinterest">
									<div data-social_link="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;media=https%3A%2F%2Flinuxconcept.com%2Fwp-content%2Fuploads%2Fgravatar%2Fsatish-kumar.jpg&#038;description=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="pinterest" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_printfriendly">
									<div data-social_link="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="printfriendly" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li></ul>
				</div>
			</div></div></a></div><div class="abh_social"> <div style="clear: both; font-size:12px; font-weight:normal; width: 85px; margin: 0 0 2px auto; line-height: 20px;">Follow me</div><a href="https://www.facebook.com/satishkumar1986" title="Facebook" class="abh_facebook" target="_blank" rel="nofollow"></a><a href="https://twitter.com/satish_kumar86" title="Twitter" class="abh_twitter" target="_blank" rel="nofollow"></a></div><div class="abh_text"><h4 style="font-size:16px !important;">Latest posts by SATISH KUMAR <span class="abh_allposts">(<a href="https://linuxconcept.com/author/satish/">see all</a>)</span></h4><div class="abh_description note" ><ul>				<li style="font-size:14px !important;" >					<a href="https://linuxconcept.com/install-java-on-debian-9-operating-system/">Install Java on Debian 9 Operating System</a>				</li>				<li style="font-size:14px !important;" >					<a href="https://linuxconcept.com/how-to-add-swap-space-on-debian-9-operating-system/">How to add swap space on Debian 9 Operating System</a>				</li>				<li style="font-size:14px !important;" >					<a href="https://linuxconcept.com/install-nginx-on-centos-7-operating-system/">Install Nginx on CentOS 7 Operating System</a>				</li></ul></div></div> </section></div> </div>
			</div>
			
		</div><div class="et_bloom_below_post"><div class="et_bloom_inline_form et_bloom_optin et_bloom_make_form_visible et_bloom_optin_3" style="display: none;">
				
				<div class="et_bloom_form_container  et_bloom_rounded et_bloom_form_text_light et_bloom_form_bottom et_bloom_inline_2_fields">
					
			<div class="et_bloom_form_container_wrapper clearfix">
				<div class="et_bloom_header_outer">
					<div class="et_bloom_form_header et_bloom_header_text_light">
						<div class="et_social_media_wrapper"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Subscribe To LinuxConcept" class="et_bloom_hide_mobile et_bloom_image_slideup et_bloom_image" data-lazy-src="https://linuxconcept.com/wp-content/plugins/bloom/images/premade-image-17.png"><noscript><img src="https://linuxconcept.com/wp-content/plugins/bloom/images/premade-image-17.png" alt="Subscribe To LinuxConcept" class="et_bloom_hide_mobile et_bloom_image_slideup et_bloom_image"></noscript><div class="et_social_media et_social_media_hidden et_social_mobile_on">
				<div class="et_social_networks et_social_autowidth et_social_simple et_social_left et_social_rounded et_social_outer_dark">
					
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<div data-social_link="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="facebook" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_twitter">
									<div data-social_link="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share" data-social_name="twitter" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_linkedin">
									<div data-social_link="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="linkedin" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_pinterest">
									<div data-social_link="http://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;media=https%3A%2F%2Flinuxconcept.com%2Fwp-content%2Fplugins%2Fbloom%2Fimages%2Fpremade-image-17.png&#038;description=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="pinterest" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li><li class="et_social_printfriendly">
									<div data-social_link="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share" data-social_name="printfriendly" data-social_type="media" data-post_id="2172" data-location="media">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										<span class="et_social_overlay"></span>
									</div>
								</li></ul>
				</div>
			</div></div>
						<div class="et_bloom_form_text">
						<h2>Subscribe To LinuxConcept</h2><p>Join world's largest Linux lovers community and get update from our team.</p>
					</div>
						
					</div>
				</div>
				<div class="et_bloom_form_content et_bloom_2_fields et_bloom_bottom_inline">
					
					
					<form method="post" class="clearfix">
						<div class="et_bloom_fields">
							<p class="et_bloom_popup_input et_bloom_subscribe_name">
								<input placeholder="Name" maxlength="50">
							</p>
							<p class="et_bloom_popup_input et_bloom_subscribe_email">
								<input placeholder="Email">
							</p>
							
							<button data-optin_id="optin_3" data-service="mailchimp" data-list_id="5a00898d76" data-page_id="2172" data-account="LinuxConcept" data-ip_address="true" class="et_bloom_submit_subscription">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_light">Join Us</span>
							</button>
						</div>
					</form>
					<div class="et_bloom_success_container">
						<span class="et_bloom_success_checkmark"></span>
					</div>
					<h2 class="et_bloom_success_message">You have successfully join the community.</h2>
					
				</div>
			</div>
			<span class="et_bloom_close_button"></span>
				</div>
			</div></div><span class="et_bloom_bottom_trigger"></span><span class="et_social_bottom_trigger"></span>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://linuxconcept.com/what-is-an-operating-system/&#038;t=What%20is%20an%20Operating%20System%3F" class="social-share-link" title="Share &quot;What is an Operating System?&quot; via Facebook" data-network-name="facebook" data-share-title="What is an Operating System?" data-share-url="https://linuxconcept.com/what-is-an-operating-system/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=What%20is%20an%20Operating%20System%3F%20https://linuxconcept.com/what-is-an-operating-system/" class="social-share-link" title="Share &quot;What is an Operating System?&quot; via Twitter" data-network-name="twitter" data-share-title="What is an Operating System?" data-share-url="https://linuxconcept.com/what-is-an-operating-system/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://linuxconcept.com/what-is-an-operating-system/&#038;description=What%20is%20an%20Operating%20System%3F&#038;media=https://linuxconcept.com/wp-content/uploads/2019/04/what-is-an-operating-system-image-150x150.png" class="social-share-link" title="Share &quot;What is an Operating System?&quot; via Pinterest" data-network-name="pinterest" data-share-title="What is an Operating System?" data-share-url="https://linuxconcept.com/what-is-an-operating-system/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://linuxconcept.com/what-is-an-operating-system/&#038;title=What%20is%20an%20Operating%20System%3F" class="social-share-link" title="Share &quot;What is an Operating System?&quot; via LinkedIn" data-network-name="linkedin" data-share-title="What is an Operating System?" data-share-url="https://linuxconcept.com/what-is-an-operating-system/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="2172" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #000000;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://linuxconcept.com/linux-cat-command-help-and-examples/" rel="prev"><span class="button">Previous</span><span class="title">Linux cat command Help and Examples</span></a>								</div>
								<div class="nav-link nav-link-next">
									<a href="https://linuxconcept.com/rsync-example-for-system-administrator/" rel="next"><span class="button">Next</span><span class="title">15 practical examples of rsync command</span></a>								</div>
							</div>
						</nav>
												<div class="et_extra_other_module author-box vcard">
							<div class="author-box-header">
								<h3>About The Author</h3>
							</div>
							<div class="author-box-content clearfix">
								<div class="author-box-avatar">
									<img alt='SATISH KUMAR' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20170%20170'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/956811c02d7e30b15f9d748da8c280a0?s=340&#038;d=mm&#038;r=g 2x' class='avatar avatar-170 photo' height='170' width='170' data-lazy-src="https://secure.gravatar.com/avatar/956811c02d7e30b15f9d748da8c280a0?s=170&#038;d=mm&#038;r=g" /><noscript><img alt='SATISH KUMAR' src='https://secure.gravatar.com/avatar/956811c02d7e30b15f9d748da8c280a0?s=170&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/956811c02d7e30b15f9d748da8c280a0?s=340&#038;d=mm&#038;r=g 2x' class='avatar avatar-170 photo' height='170' width='170' /></noscript>								</div>
								<div class="author-box-description">
									<h4><a class="author-link url fn" href="https://linuxconcept.com/author/satish/" rel="author" title="View all posts by SATISH KUMAR">SATISH KUMAR</a></h4>
									<p class="note">I am Satish Kumar, Founder of LinuxConcept. Linux and F.O.S.S enthusiast, love to work on open source platform and technologies.</p>
									<ul class="social-icons">
																			</ul>
								</div>
							</div>
						</div>
						
												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://linuxconcept.com/top-10-linux-distribution-2019/" title="Top 10 Linux Distribution – 2019" class="post-thumbnail">
				<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Top 10 Linux Distribution – 2019" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/04/Top-10-Linux-Distro-2019-image-440x264.png" /><noscript><img src="https://linuxconcept.com/wp-content/uploads/2019/04/Top-10-Linux-Distro-2019-image-440x264.png" alt="Top 10 Linux Distribution – 2019" /></noscript><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://linuxconcept.com/top-10-linux-distribution-2019/">Top 10 Linux Distribution – 2019</a></h4>
									<p class="date"><span class="updated">Last updated on Apr 9, 2019 | Published on Apr 8, 2019</span></p>
								</div>
																							</div>
						</div>
										
				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/what-is-an-operating-system/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://linuxconcept.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2172' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b43dbc35f9" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="245"/></p>			</form>
			</div><!-- #respond -->
		</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://linuxconcept.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div> <!-- end .et_pb_widget --><div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">Linux Certification</h4>			<div class="textwidget"><p><a href="https://linuxconcept.com/rhcsa-certification-guide/"><img class="aligncenter wp-image-1875 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - RHCSA Red Hat Certified System Administrator" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/RHCSA.png" /><noscript><img class="aligncenter wp-image-1875 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/RHCSA.png" alt="Linux Concept - RHCSA Red Hat Certified System Administrator" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/rhce-certification-guide/"><img class="aligncenter wp-image-1876 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - RHCE Red Hat Certified Engineer" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/RHCE.png" /><noscript><img class="aligncenter wp-image-1876 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/RHCE.png" alt="Linux Concept - RHCE Red Hat Certified Engineer" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/lfcs-certification-guide/"><img class="aligncenter wp-image-1877 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - LFCS Linux Foundation Certified SysAdmin" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/LFCS.png" /><noscript><img class="aligncenter wp-image-1877 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/LFCS.png" alt="Linux Concept - LFCS Linux Foundation Certified SysAdmin" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/lfce-certification-guide/"><img class="aligncenter wp-image-1878 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - LFCE Linux Foundation Certified Engineer" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/LFCE.png" /><noscript><img class="aligncenter wp-image-1878 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/LFCE.png" alt="Linux Concept - LFCE Linux Foundation Certified Engineer" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/lpi-essentials-certification-guide/"><img class="aligncenter wp-image-1879 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - LPI Linux Professional Institute Essentials" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/LPI.png" /><noscript><img class="aligncenter wp-image-1879 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/LPI.png" alt="Linux Concept - LPI Linux Professional Institute Essentials" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/lpic-1-linux-administrator-certification-guide/"><img class="aligncenter wp-image-1880 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - LPIC-1 Linux Administrator" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/LPIC-1-Linux-Administrator.png" /><noscript><img class="aligncenter wp-image-1880 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/LPIC-1-Linux-Administrator.png" alt="Linux Concept - LPIC-1 Linux Administrator" width="360" height="72" /></noscript></a></p>
<p><a href="https://linuxconcept.com/lpic-2-linux-engineer-certification-guide/"><img class="aligncenter wp-image-1881 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20360%2072'%3E%3C/svg%3E" alt="Linux Concept - LPIC-2 Linux Engineer" width="360" height="72" data-lazy-src="https://linuxconcept.com/wp-content/uploads/2019/03/LPIC-2-Linux-Engineer.png" /><noscript><img class="aligncenter wp-image-1881 size-full" src="https://linuxconcept.com/wp-content/uploads/2019/03/LPIC-2-Linux-Engineer.png" alt="Linux Concept - LPIC-2 Linux Engineer" width="360" height="72" /></noscript></a></p>
</div>
		</div> <!-- end .et_pb_widget -->		<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul>
											<li>
					<a href="https://linuxconcept.com/install-java-on-debian-9-operating-system/">Install Java on Debian 9 Operating System</a>
									</li>
											<li>
					<a href="https://linuxconcept.com/how-to-add-swap-space-on-debian-9-operating-system/">How to add swap space on Debian 9 Operating System</a>
									</li>
											<li>
					<a href="https://linuxconcept.com/install-nginx-on-centos-7-operating-system/">Install Nginx on CentOS 7 Operating System</a>
									</li>
											<li>
					<a href="https://linuxconcept.com/install-mariadb-on-centos-7-operating-system/">Install MariaDB on CentOS 7 Operating System</a>
									</li>
											<li>
					<a href="https://linuxconcept.com/install-mysql-on-centos-7-operating-system/">Install MySQL on CentOS 7 Operating System</a>
									</li>
					</ul>
		</div> <!-- end .et_pb_widget --><div id="bloomwidget-2" class="et_pb_widget widget_bloomwidget"><h4 class="widgettitle">LET’S CONNECT!</h4>
				<div class='et_bloom_widget_content et_bloom_make_form_visible et_bloom_optin et_bloom_optin_2' style='display: none;'>
					<style type="text/css">.et_bloom .et_bloom_optin_2 .et_bloom_form_container .et_bloom_form_header { background-color: #ffffff !important; } .et_bloom .et_bloom_optin_2 .et_bloom_form_container h2, .et_bloom .et_bloom_optin_2 .et_bloom_form_container h2 span, .et_bloom .et_bloom_optin_2 .et_bloom_form_container h2 strong { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; }.et_bloom .et_bloom_optin_2 .et_bloom_form_container p, .et_bloom .et_bloom_optin_2 .et_bloom_form_container p span, .et_bloom .et_bloom_optin_2 .et_bloom_form_container p strong, .et_bloom .et_bloom_optin_2 .et_bloom_form_container form input, .et_bloom .et_bloom_optin_2 .et_bloom_form_container form button span { font-family: "Open Sans", Helvetica, Arial, Lucida, sans-serif; } </style>
					<div class='et_bloom_form_container et_bloom_rounded et_bloom_form_text_dark'>
						
			<div class="et_bloom_form_container_wrapper clearfix">
				<div class="et_bloom_header_outer">
					<div class="et_bloom_form_header et_bloom_header_text_dark">
						
						
						
					</div>
				</div>
				<div class="et_bloom_form_content et_bloom_2_fields et_bloom_bottom_stacked">
					
					
					<form method="post" class="clearfix">
						<div class="et_bloom_fields">
							<p class="et_bloom_popup_input et_bloom_subscribe_name">
								<input placeholder="Name" maxlength="50">
							</p>
							<p class="et_bloom_popup_input et_bloom_subscribe_email">
								<input placeholder="Email">
							</p>
							
							<button data-optin_id="optin_2" data-service="mailchimp" data-list_id="5a00898d76" data-page_id="2172" data-account="LinuxConcept" data-ip_address="true" class="et_bloom_submit_subscription">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_dark">SUBSCRIBE!</span>
							</button>
						</div>
					</form>
					<div class="et_bloom_success_container">
						<span class="et_bloom_success_checkmark"></span>
					</div>
					<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
					
				</div>
			</div>
			<span class="et_bloom_close_button"></span>
					</div>
				</div></div> <!-- end .et_pb_widget --><div id="text-3" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><p><a target="_blank" href="https://indibloghub.com" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" title="Indian Bloggers Community" alt="Indian Bloggers Community" style="border: 1;" data-lazy-src="https://indibloghub.com/public/images/indi_badge_1.png"><noscript><img src="https://indibloghub.com/public/images/indi_badge_1.png" title="Indian Bloggers Community" alt="Indian Bloggers Community" style="border: 1;"></noscript></a></p>
</div>
		</div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_3">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-1791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1791"><a href="https://linuxconcept.com/subscribe-to-blog/">Subscribe</a></li>
<li id="menu-item-1792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1792"><a href="https://linuxconcept.com/linux-services/">Services</a></li>
<li id="menu-item-1793" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1793"><a href="https://linuxconcept.com/feedback/">Feedback</a></li>
<li id="menu-item-1794" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1794"><a href="https://linuxconcept.com/copyright-policy/">Copyright Policy</a></li>
<li id="menu-item-1795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1795"><a href="https://linuxconcept.com/privacy-policy/">Privacy Policy</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/linuxconcept" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/Linux_Concept" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																																				</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	
	<div id="cookie-law-info-bar"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish.<a  data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">Accept</a> <a href='https://linuxconcept.com/privacy-policy/' id="CONSTANT_OPEN_URL" target="_blank"  class="cli-plugin-main-link"  style="display:inline-block;" >Read More</a></span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
    <div class="cli-modal-content cli-bar-popup">
      <button type="button" class="cli-modal-close" id="cliModalClose">
        <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
      </button>
      <div class="cli-modal-body">
        <div class="cli-container-fluid cli-tab-container">
    <div class="cli-row">
        <div class="cli-col-12 cli-align-items-stretch cli-px-0">
            <div class="cli-privacy-overview">
                                                   
                <div class="cli-privacy-content">
                    <p class="cli-privacy-content-text"></p>
                </div>
                <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a>            </div>
        </div>  
        <div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
            <div class="cli-tab-section cli-privacy-tab">
                <div class="cli-tab-header">
                    <a class="cli-nav-link cli-settings-mobile" >
                                            </a>
                </div>
                <div class="cli-tab-content">
                    <div class="cli-tab-pane cli-fade">
                        <p></p>
                    </div>
                </div>

            </div>
              
           
                            <div class="cli-tab-section">
                    <div class="cli-tab-header">
                        <a class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" >
                            Necessary 
                        </a>
                    
                    <span class="cli-necessary-caption">Always Enabled</span>                     </div>
                    <div class="cli-tab-content">
                        <div class="cli-tab-pane cli-fade" data-id="necessary">
                            <p></p>
                        </div>
                    </div>
                </div>
              
           
                            <div class="cli-tab-section">
                    <div class="cli-tab-header">
                        <a class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab" >
                            Non-necessary 
                        </a>
                    <div class="cli-switch">
                        <input type="checkbox" id="checkbox-non-necessary" class="cli-user-preference-checkbox" data-id="checkbox-non-necessary" checked />
                        <label for="checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled">Non-necessary</label>
                    </div>                    </div>
                    <div class="cli-tab-content">
                        <div class="cli-tab-pane cli-fade" data-id="non-necessary">
                            <p></p>
                        </div>
                    </div>
                </div>
                       
        </div>
    </div> 
</div> 
      </div>
    </div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<script type="text/javascript">
  /* <![CDATA[ */
  cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#000","button_1_button_hover":"#000000","button_1_link_colour":"#fff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"button_2_hidebar":true,"button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#fff","button_4_as_button":true,"font_family":"inherit","header_fix":false,"notify_animate_hide":false,"notify_animate_show":true,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":true,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":true,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';
  /* ]]> */
</script><div class="et_bloom_popup et_bloom_optin et_bloom_resize et_bloom_optin_4 et_bloom_auto_popup et_bloom_trigger_bottom" data-delay="5">
							<div class="et_bloom_form_container et_bloom_popup_container et_bloom_form_bottom with_edge wedge_edge et_bloom_rounded et_bloom_form_text_light et_bloom_animation_fadein">
								
			<div class="et_bloom_form_container_wrapper clearfix">
				<div class="et_bloom_header_outer">
					<div class="et_bloom_form_header et_bloom_header_text_light">
						<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Subscribe To LinuxConcept" class=" et_bloom_image_slideup et_bloom_image" data-lazy-src="https://linuxconcept.com/wp-content/plugins/bloom/images/premade-image-17.png"><noscript><img src="https://linuxconcept.com/wp-content/plugins/bloom/images/premade-image-17.png" alt="Subscribe To LinuxConcept" class=" et_bloom_image_slideup et_bloom_image"></noscript>
						<div class="et_bloom_form_text">
						<h2>Subscribe To LinuxConcept</h2><p>Join the world's larget Linux lover Community and get updates from our team.</p>
					</div>
						
					</div>
				</div>
				<div class="et_bloom_form_content et_bloom_2_fields et_bloom_bottom_inline">
					
					<svg class="triangle et_bloom_default_edge" xmlns="http://www.w3.org/2000/svg" version="1.1" width="100%" height="20" viewBox="0 0 100 100" preserveAspectRatio="none">
						<path d="M0 0 L50 100 L100 0 Z" fill=""></path>
					</svg>
					<form method="post" class="clearfix">
						<div class="et_bloom_fields">
							<p class="et_bloom_popup_input et_bloom_subscribe_name">
								<input placeholder="Name" maxlength="50">
							</p>
							<p class="et_bloom_popup_input et_bloom_subscribe_email">
								<input placeholder="Email">
							</p>
							
							<button data-optin_id="optin_4" data-service="mailchimp" data-list_id="5a00898d76" data-page_id="2172" data-account="LinuxConcept" data-ip_address="true" class="et_bloom_submit_subscription">
								<span class="et_bloom_subscribe_loader"></span>
								<span class="et_bloom_button_text et_bloom_button_text_color_light">Join US</span>
							</button>
						</div>
					</form>
					<div class="et_bloom_success_container">
						<span class="et_bloom_success_checkmark"></span>
					</div>
					<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
					
				</div>
			</div>
			<span class="et_bloom_close_button"></span>
							</div>
						</div><div class="et_social_pin_images_outer">
					<div class="et_social_pinterest_window">
						<div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div>
						<div class="et_social_pin_images" data-permalink="https://linuxconcept.com/what-is-an-operating-system/" data-title="What is an Operating System?" data-post_id="2172"></div>
					</div>
				</div><div class="et_social_sidebar_networks et_social_visible_sidebar et_social_slideright et_social_animated et_social_rectangle et_social_sidebar_grow et_social_sidebar_withcounts et_social_withtotalcount et_social_mobile_off">
					<div class="et_social_totalcount et_social_dark">
							<span class="et_social_totalcount_count et_social_total_share" data-post_id="2172"></span>
							<span class="et_social_totalcount_label">Shares</span>
						</div>
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;t=What%20is%20an%20Operating%20System%3F" class="et_social_share et_social_display_count" rel="nofollow" data-social_name="facebook" data-post_id="2172" data-social_type="share" data-location="sidebar"data-min_count="21">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="http://twitter.com/share?text=What%20is%20an%20Operating%20System%3F&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;via=Linux_Concept" class="et_social_share et_social_display_count" rel="nofollow" data-social_name="twitter" data-post_id="2172" data-social_type="share" data-location="sidebar"data-min_count="21">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_linkedin">
									<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share et_social_display_count" rel="nofollow" data-social_name="linkedin" data-post_id="2172" data-social_type="share" data-location="sidebar"data-min_count="21">
										<i class="et_social_icon et_social_icon_linkedin"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_pinterest">
									<a href="#" class="et_social_share_pinterest et_social_display_count" rel="nofollow" data-social_name="pinterest" data-post_id="2172" data-social_type="share" data-location="sidebar"data-min_count="21">
										<i class="et_social_icon et_social_icon_pinterest"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_like">
									<a href="" class="et_social_share" rel="nofollow" data-social_name="like" data-post_id="2172" data-social_type="like" data-location="sidebar">
										<i class="et_social_icon et_social_icon_like"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_printfriendly">
									<a href="http://www.printfriendly.com/print?url=https%3A%2F%2Flinuxconcept.com%2Fwhat-is-an-operating-system%2F&#038;title=What%20is%20an%20Operating%20System%3F" class="et_social_share et_social_display_count" rel="nofollow" data-social_name="printfriendly" data-post_id="2172" data-social_type="share" data-location="sidebar"data-min_count="21">
										<i class="et_social_icon et_social_icon_printfriendly"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li></ul>
					<span class="et_social_hide_sidebar et_social_icon"></span>
				</div>	<script type="text/javascript">
			</script>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-134861445-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-134861445-1');
</script>
<link rel='stylesheet' id='et_bloom-css-css'  href='https://linuxconcept.com/wp-content/plugins/bloom/css/style.css?ver=1.3.10' type='text/css' media='all' />
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/monarch/js/idle-timer.min.js?ver=1.4.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/linuxconcept.com\/what-is-an-operating-system\/","stats_nonce":"ae3bf3f0db","share_counts":"e71a773ada","follow_counts":"2fa5394899","total_counts":"fd1fa17b42","media_single":"b3052215c3","media_total":"cfb165ca48","generate_all_window_nonce":"c3cb41932d","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/monarch/js/custom.js?ver=1.4.12'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/linuxconcept.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"9e71e44e62","timeline_nonce":"7761b6cee6","blog_feed_nonce":"cb971aa728","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/linuxconcept.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/linuxconcept.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"9afd9bc79c","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"c2657da2f8","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"2172","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.27.1'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/themes/Extra/core/admin/js/common.js?ver=3.27.1'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/bloom/js/jquery.uniform.min.js?ver=1.3.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bloomSettings = {"ajaxurl":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/linuxconcept.com\/what-is-an-operating-system\/","stats_nonce":"57cdf2d5c8","subscribe_nonce":"ce24ee7ab8","is_user_logged_in":"not_logged"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/bloom/js/custom.js?ver=1.3.10'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/bloom/js/idle-timer.min.js?ver=1.3.10'></script>
<script async="async" type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _spTr = {"optimizeWithSP":"Optimize with ShortPixel","redoLossy":"Re-optimize Lossy","redoGlossy":"Re-optimize Glossy","redoLossless":"Re-optimize Lossless","restoreOriginal":"Restore Originals","changeMLToListMode":"In order to access the ShortPixel Optimization actions and info, please change to {0}List View{1}List View{2}Dismiss{3}","alertOnlyAppliesToNewImages":"This type of optimization will apply to new uploaded images. Images that were already processed will not be re-optimized unless you restart the bulk process.","areYouSureStopOptimizing":"Are you sure you want to stop optimizing the folder {0}?","reducedBy":"Reduced by","bonusProcessing":"Bonus processing","plusXthumbsOpt":"+{0} thumbnails optimized","plusXretinasOpt":"+{0} Retina images optimized","optXThumbs":"Optimize {0} thumbnails","reOptimizeAs":"Reoptimize {0}","restoreBackup":"Restore backup","getApiKey":"Get API Key","extendQuota":"Extend Quota","check__Quota":"Check\u00a0\u00a0Quota","retry":"Retry","thisContentNotProcessable":"This content is not processable.","imageWaitOptThumbs":"Image waiting to optimize thumbnails","pleaseDoNotSetLesserSize":"Please do not set a {0} less than the {1} of the largest thumbnail which is {2}, to be able to still regenerate all your thumbnails in case you'll ever need this.","pleaseDoNotSetLesser1024":"Please do not set a {0} less than 1024, to be able to still regenerate all your thumbnails in case you'll ever need this.","confirmBulkRestore":"Are you sure you want to restore from backup all the images in your Media Library optimized with ShortPixel?","confirmBulkCleanup":"Are you sure you want to cleanup the ShortPixel metadata info for the images in your Media Library optimized with ShortPixel? This will make ShortPixel 'forget' that it optimized them and will optimize them again if you re-run the Bulk Optimization process.","confirmBulkCleanupPending":"Are you sure you want to cleanup the pending metadata?","alertDeliverWebPAltered":"Warning: Using this method alters the structure of the rendered HTML code (IMG tags get included in PICTURE tags),\nwhich in some rare cases can lead to CSS\/JS inconsistencies.\n\nPlease test this functionality thoroughly after activating!\n\nIf you notice any issue, just deactivate it and the HTML will will revert to the previous state.","alertDeliverWebPUnaltered":"This option will serve both WebP and the original image using the same URL, based on the web browser capabilities, please make sure you're serving the images from your server and not using a CDN which caches the images."};
var ShortPixelConstants = [{"STATUS_SUCCESS":1,"STATUS_EMPTY_QUEUE":0,"STATUS_ERROR":-1,"STATUS_FAIL":-2,"STATUS_QUOTA_EXCEEDED":-3,"STATUS_SKIP":-4,"STATUS_NO_KEY":-6,"STATUS_RETRY":-7,"STATUS_QUEUE_FULL":-404,"STATUS_MAINTENANCE":-500,"STATUS_SEARCHING":-8,"WP_PLUGIN_URL":"https:\/\/linuxconcept.com\/wp-content\/plugins\/shortpixel-image-optimiser","WP_ADMIN_URL":"https:\/\/linuxconcept.com\/wp-admin\/","API_KEY":"","DEFAULT_COMPRESSION":1,"MEDIA_ALERT":"todo","FRONT_BOOTSTRAP":1,"AJAX_URL":"https:\/\/linuxconcept.com\/wp-admin\/admin-ajax.php","AFFILIATE":false}];
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/shortpixel-image-optimiser/res/js/shortpixel.min.js?ver=4.14.3'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/shortpixel-image-optimiser/res/js/jquery.knob.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/shortpixel-image-optimiser/res/js/jquery.tooltip.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://linuxconcept.com/wp-content/plugins/shortpixel-image-optimiser/res/js/punycode.min.js?ver=5.2.2'></script>
<style id="et-builder-module-design-cached-inline-styles">.et_pb_text_1{padding-right:10px!important;padding-left:10px!important;box-shadow:6px 6px 18px 0px rgba(0,0,0,0.3)}.et_pb_text_2{padding-right:10px!important;padding-left:10px!important;box-shadow:6px 6px 18px 0px rgba(0,0,0,0.3)}.et_pb_text_5{padding-left:42px!important;margin-top:-21px!important}.et_pb_section_1{border-color:#E02B20}.et_pb_row_1{background-color:rgba(132,132,132,0.49);border-width:6px;border-style:double}.et_pb_column_0{z-index:9;position:relative}.et_pb_column_1{z-index:9;position:relative}</style><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://linuxconcept.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->